
 
 

DataSuite Installation and 

Registration Guide  

This document provides a detailed overview of the installation 
and registration procedure for the DataSuite software. 
DataSuite allows you to configure and monitor a range of 
fourtec data loggers within a single, unified Windows-based 
application. DataSuite is a modular software, and shares its 
core functionality such as setup, calibration, defining new 
sensors, managing Email and SMS notifications, configuring 
reports, and firmware updates amongst devices such as 
DaqLink, DataNet, MicroLite II and MicroLogPRO II.  

1.1. Installing DataSuite Software 

Follow the software installation instructions provided below.  

1.1.1. System Requirements 

To work with DataSuite your system should be configured according to the following 
specifications: 

Software 

 Windows XP SP3, Windows Server 2003 SP2, Windows Vista or Windows 7 (32-bit 
or 64-bit) 

 Minimum screen resolution: 1024 x 768 (800 x 600 not supported) 

Hardware 

 Pentium 4, 2.0 GHz or better  

 512 MB RAM  

 250 MB available disk space for the DataSuite application  

1.1.2. Language Support 

DataSuite currently supports English interface only with additional languages to be 
added in future DataSuite versions. 

To toggle the software language, go to Help > Language. You must then exit DataSuite 
for the changes to take effect.  



 
 

1.1.3. Working with User Accounts 

The software installation procedure and license activation process must both be carried 
out by a user with Administrator privileges, other there will be problems accessing the 
software by user’s with standard non-Admin privileges. 

Each specific user account that accesses the DataSuite software module can 
commence trial period for that specific account. However, as soon as a user with 
Administrator privileges activates the module with the unique license serial number, then 
all user accounts which had previously been in Trial mode, will now be fully activated.  

All users will have full access to the DataSuite module’s settings and data files.  

1.1.4. Installation Procedure 

Note: If you are planning to use more than one fourtec system e.g. DataNet and 
MicroLogPRO II, only one DataSuite software installation is required. Each product is 
managed by a specific product module within the DataSuite modular application. 

 

Note: Remember that the installation procedure must be carried out by a user with 
Administrator privileges. 

 

Please read these instructions before proceeding with the installation process. 

1. Insert the DataSuite software CD into your computer’s CD drive. The DataSuite 
Installation Wizard automatically starts running. 

2. The Wizard first installs Microsoft .NET Framework 3.5, if not already detected on 
the computer. The DataSuite software requires this platform in order to run. Follow 
the installation instructions to install the .NET Framework on your PC. This step can 
take up to two minutes to complete. Click Finish once installation is complete. 

Note: If .NET Framework is already installed on your computer this step is skipped. 

3. The main DataSuite Installation Wizard now resumes. Follow the installation 
instructions to install DataSuite on your computer.  

4. Following DataSuite software installation is the Silicon Laboratories USB driver 
installation. The driver is necessary for the computer to detect the DataNet and 
DaqLink hardware.  

Note: MicroLogPRO II and MicroLite II do not require driver installation. 

5. Follow the on-screen instructions to continue the installation process. The default 
installation location is C:\SiLabs. 



 
 

 

Figure 1: Installing Silicon Labs USB driver – Step 1  

6. During the driver installation, the following window will pop up. Make sure to select 
the checkbox to launch the driver installer, and click Finish. 

 

Figure 2: Installing Silicon Labs USB driver – Step 2 

7. In the subsequent window, click Install to install the driver. 

 

Figure 3: Installing Silicon Labs USB driver – Step 3 

 

The installation of the driver could take up to one minute or more, depending on the 
system.  

 

Figure 4: Installing Silicon Labs USB driver – Step 4 

 

8. Once installed click Finish to close the USB driver Install Wizard dialog. 



 
 

9. The DataSuite software and components have now been installed. Double click the 

DataSuite shortcut on your desktop  to launch the software. 

10. The DataSuite Welcome window will open, prompting the user to configure the 
application before use. This must be done only once when first running the software. 
Click Next to continue. 

11. You are then given the choice to activate the DataSuite software now or to do so 
later. To activate now click Next, to activate later click Skip. Even if the software is 
not activated using the license Serial Number, you still need to commence the Trial 
period in order to use the hardware.  

 

12. When choosing to activate the software, the DataSuite software registration window 
will open. Select the relevant module button e.g. DaqLink.  



 
 

 

13. Select Start trial to commence the free 30-day trial and click Next. The module 
registration can be completed at a later stage. For more details refer to section ‎1.3. 

14. Once the Trial period has started, DataSuite will detect the connected loggers. To 
detect more than one product module at the same time, you must ensure that each 
module is either in Trial mode or activated using the unique software Serial Number.  

15. When completing the necessary tasks in the Validation window, click Exit. You will 
return to the window from step 11 above. Click Skip.  

16. In specific versions of Windows, the user may have User Account Control (UAC) 
settings activated. If so, the user will be prompted the following instructions. Select 
the relevant option. 



 
 

 

17. If you have an existing, activated DataNet installation on the same computer, then 
DataSuite will detect it. You have the option to convert all data files from these 
previous installations into a format recognized by DataSuite. This will allow you to 
view all archived data in DataSuite as well as in the legacy software. Click Next to 
convert the data, or Skip to skip this step. If you skip, you will not be able to convert 
the data files later. 

 

18. You have reached the end of the configuration process. Click Finish to launch the 
application. 

19. Once the module is launched, connect the device to a USB port on your computer. It 
will automatically detect the logger as new hardware and the device will appear as a 
new icon in the DataSuite Map View.  

1.1.5. Installation Troubleshooting 

When connected to the PC USB port the device was not detected by the software. 

Ensure that the USB driver was installed properly.  



 
 

Go to Control Panel > Add/Remove Programs (in WinXP), and check that the driver is 
installed: 

 

 

If not, you should run the Silicon Labs setup file to install the USB driver: 
CP210x_VCP_Win2K_XP_S2K3.exe setup.exe to install the driver.  

 

If the driver is installed, ensure that there is no other device sharing the USB com port 
with the device.  

If you didn’t select the Launch CP210x VCP Driver Installer checkbox during step 2 of 
the driver installation wizard (see section ‎1.1.2), then the driver wasn’t installed. Run the 
wizard again and be sure to select the checkbox. 

1.2. DataSuite CFR Login 

When launching the DataSuite CFR software (following activation of the CFR module), 
the user is required to login to the system so that the system Administrator is able to 
follow user activity in the DatPass Admin software audit trail (per FDA regulations). 

1. Prior to commencing trial period or activating the DataSuite CFR module, the Admin 
must first install the DatPass software and create a new user ID.  

2. Once DatPass is installed and a valid user has been created, you start the 
trial/activate the CFR module. 

3. The Login dialog will open. For first time login, click New User.  

 

Figure 5: User Login Dialog 

4. Select the user via the drop-down menu, and proceed to enter the username and 
password associated with that user profile. 

Note: If the system prompts a No New Users message, then request your DataSuite 
system administrator create a new user in DatPass. 

5. Click OK. 



 
 

6. Once logged into the DataSuite CFR software, you will only have access to those 
features for which the Administrator has granted privileges. 

7. To log off from the system, go to File > Logoff. The login dialog will remain open in 
case you wish to login again. 

Note: Once you have activated DataSuite CFR, you cannot deactivate it and return to a 
non-CFR environment. 

1.3. DataSuite Software Registration 

DataSuite requires all modules to be registered within 30 days of installation, using a 
serial number provided with purchase of the specific DataSuite module:  

 DataSuite-DN (DataNet) 

 DataSuite-DQL (DaqLink) 

 DataSuite-ML (MicroLogPRO II) 

 DataSuite-CFR (CFR module) 

 DataSuite for MicroLite is free of charge and does not require activation. 

 When the initial 30 day Trial period is over, the user will not be able to operate the 
software until a valid serial number is registered.  

Note: The software activation feature protects fourtec’s intellectual property for both its 
software and hardware.  

 

Please note that: 

 Each serial number is good for unlimited installations on a single computer. You 
cannot install the software using the same serial number on another computer.  

If you have replaced your computer and must reinstall DataSuite using the same 
serial number, contact fourtec Customer Support for assistance. 

 Registration can be performed from the computer with DataSuite installed, or if there 
is no Internet connection from that computer, then via another computer with Internet 
connectivity. 

 When the trial period for the CFR module ends, DataSuite will revert to the standard 
non-CFR environment unless activated. 

1.3.1. Software Registration Process 

Note: The software registration forms are all case sensitive. Incorrect entry will result in 
invalid registration.  

To register any one of the DataSuite modules, follow the instructions below: 

1. Locate the DataSuite module serial number (SN). The SN label is found on the 
DataSuite box as well as on the software CD case. 

Note: If you cannot locate your serial number, contact your fourtec distributor or fourtec 
Customer Support directly. 



 
 

2. Launch DataSuite. The registration wizard will open.  

3. To open the registration wizard from within DataSuite go to Help > Register. 

4. From the bottom of the wizard Home screen, select one of the module buttons to 
proceed to the registration screen for that module. 

 

5. Three choices are presented. Select the relevant option and click Next to proceed: 

 



 
 

 Activation via the Internet 

Select to proceed with registration on the same computer on which DataSuite is 
running, ensuring it has a live Internet connection. 

 Activation via an Internet connection on another computer  

Select if the computer on which DataSuite is running does not currently have 
Internet connectivity.  

 Start  trial  

Select to commence the 30 day free trial period and continue working in 
DataSuite.  

6. After selecting one of the two available options for continuing with the registration 
process, and after clicking Next in step 4 above, you will be prompted to enter the 
software SN. Enter the SN and click Next. 

Note: Each serial number provides a single user license for the specific module. You 
cannot use a serial number already registered on another computer.  

7. The registration process now differs, depending on which option was selected in step 
4 above. Read the relevant section below for further registration instructions.  

 

Activation via the Internet 

1. After entering the software serial number, a window requesting basic personal 
information will open. Enter the mandatory fields and click Next.  

 

Figure 6: Personal information registration window 



 
 

2. DataSuite will now establish communication with the fourtec server to complete the 
registration process. If successful, a confirmation message will appear. In the event 
of any problem in the registration process, please contact your fourtec distributor or 
fourtec Customer Support.  

3. Click Close to return to the DataSuite software. 

 

Activation via Internet Connection on another Computer 

1. After entering the software serial number, a window providing additional registration 
instructions will open.  

  

Figure 7: Activating DataSuite from another computer 

 

2. Follow the steps as outlined in the window.  

Note: It is recommended to generate a text file containing both the Application Key and 

the Web registration form URL. Press the  icon. Transfer this file to the computer 
with Internet connection, as the registration process must be continued from there.  

3. Record the License Key obtained from the Web registration form. Enter it into the 
License Key field in Step 1 and click Unlock. 



 
 

4. DataSuite will now establish communication with the fourtec server to complete the 
registration process. If successful, a confirmation message will appear. In the event 
of any problem in the registration process, please contact your fourtec distributor or 
fourtec Customer Support.  

5. Click Close to return to the DataSuite software. 
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